Como mover sinal na posição errada (Excel)

Uma aluna apareceu com o seguinte problema, que pode ser comum a outras pessoas: “quando importo uma tabela de um sistema contábil e colo no Excel, os números ficam com sinais de positivo ou negativo à direita e não à esquerda como é o normal e tenho de deletar um por um, às vezes são dezenas”

Isso pode ser resolvido facilmente usando funções de texto (ESQUERDA, DIREITA, NÚM.CARACT) e VALOR (função para conversão de texto para valor numérico) combinadas na função lógica SE.

Exel sinal trocado

  Suponha que na célula A2 tenha o primeiro número a ser “convertido”, a fórmula (em B2) ficará:

=SE(DIREITA(A2)=”+”;VALOR(ESQUERDA(A2;NÚM.CARACT(A2)-1));VALOR(“-“&ESQUERDA(A2;NÚM.CARACT(A2)-1)))

Depois disso basta “arrastar” a fórmula (ou copiar a célula e colar nas demais) para as próximas linhas…

One thought on “Como mover sinal na posição errada (Excel)

  1. Olá,

    resolvi o problema de outro jeito. Visto que o programa que utilizo não acrescenta o sinal de + à direta, criei a seguinte fórmula:

    =SE(DIREITA(F1;1)=”-“;CONCATENAR(“-“;ESQUERDA(F1;NÚM.CARACT(F1)-1));F1)

Comments are closed.