SOMASE duplo no Excel

Para quem tem o EXCEL 2007, existe uma nova função o SOMASES (com uma letra “s” no fim) que permite mais de uma condição.

Por exemplo, quero somar a coluna “total” (de C3 a C12) apenas para o “joão” e apenas para a data “14/01/2010”. No Excel a partir da versão 2007, isso é possível com esta nova função SOMASES.

tabela excel com 3 colunas

Somase com 2 condições: como fazer?

Para o Excel 2007 ou posterior, teremos:

=SOMASES(C3:C12;A3:A12;”joão”;B3:B12;DATA(2010;1;14))

(Observação: não pude testar, não tenho o Excel 2007)

Bom… Para a maioria dos coitados que como eu só tem o 2003, é possível resolver o problema adicionando uma coluna extra onde os critérios “joão” e data(2010;1;14) sejam usados na fórmula lógica

=E(A3=”joão”;B3=DATA(2010;1;14))

para mostrar os resultados FALSO ou VERDADEIRO. Abaixo, coloquei a fórmula acima na célula E3 e arrastei-a para as outras células abaixo:

coluna extra para o somase Agora posso fazer um SOMASE normal para obter o resultado desejado: =SOMASE(E3:E12;VERDADEIRO;C3:C12).

Outra maneira de resolver o problema (minha solução favorita) é, ao invés de escrever FALSO ou VERDADEIRO, concatenar os nomes e as datas em uma única célula. Fica esquisito, porque para o Excel, uma data é o número de dias a partir de primeiro de janeiro de 1900, ao usar em E3 a fórmula

=A3&B3

ou

=CONCATENAR(A3;B3)

ficaremos com a planilha assim:

planilha com fórmula somaseA fórmula SOMASE usada na planilha acima é:

=SOMASE(E3:E12;”joão40192″;C3:C12)

o número 40192 é o número de dias existentes entre 1/1/1900 e 14/1/2010 incluindo ambos.

Por fim, uma solução mais esquisita ainda, mas que dispensa o uso de uma coluna extra: também é possível resolver o problema por uma fórmula menos conhecida, a fórmula SOMARPRODUTO. Neste caso, basta usar a fórmula:

=SOMARPRODUTO(- -(A3:A12=”joão”);- -(B3:B12=DATA(2010;1;14));- -(C3:C12))

Observe que a função DATA requer que ano, mês e dia sejam digitadas exatamente nesta ordem. Os dois sinais negativos na fórmula são uma maneira de converter resultados numérico para valores lógicos e “enganar” a função SOMARPRODUTO.

Bom, depois de toda essa trabalheira, cada vez acho mais conveniente migrar para o Office 2007…

Dúvidas? é só mandar um e-mail, visite minha página de Informática: www.naotemnome.com/fapa lá tem o meu e-mail… E dicas para Excel, basta olhar no índice!